Почему отличается предпросмотр в adobe Premiere Pro от плеера

  • Похожие темы
    Ответы
    Просмотры
    Последнее сообщение
Монтируем видео
Canonical Link
Аватара пользователя

aeplug
Санта
Санта
Сообщения: 2471
Зарегистрирован: 18 мар 2016 23:20
Откуда: С Ютуба
Благодарил (а): 16 раз
Поблагодарили: 251 раз

Сообщение aeplug » 06 июл 2019 15:08

А файл из Premiere Pro как потом в самом Premiere Pro показывается? Искажено?


Видео уроки для After Effects http://www.youtube.com/AEPlug
Платные консультации по работе в программах



Nuk_pro
Нуб
Нуб
Сообщения: 2
Зарегистрирован: 23 фев 2020 17:50

Та же проблема

Сообщение Nuk_pro » 23 фев 2020 18:02

Столкнулся с той же бедой.
При этом при рендере в avi без кодеков - цвет в проигрывателях нормальный. Но если avi конвертировать через разные кодеки - также видео в серую муть превращается.
Нашел на каком-то форуме - товарищ сам искал выход из такой проблемы и нашел следующий - конвертировать в лослесс Ави, закидывать в сони Вегас. в Вегасе есть кодек сони таблет, который даёт нормальный цвет на выходе. Сам ещё не пробовал.
Может у вас есть решение проще?

Аватара пользователя

aeplug
Санта
Санта
Сообщения: 2471
Зарегистрирован: 18 мар 2016 23:20
Откуда: С Ютуба
Благодарил (а): 16 раз
Поблагодарили: 251 раз

Сообщение aeplug » 23 фев 2020 23:58

Вы хоть что-то покажите, файлы, исходники, картинки, а то слова одни.
Видео уроки для After Effects http://www.youtube.com/AEPlug
Платные консультации по работе в программах


Nuk_pro
Нуб
Нуб
Сообщения: 2
Зарегистрирован: 23 фев 2020 17:50

Сообщение Nuk_pro » 25 фев 2020 00:05

aeplug писал(а):Источник цитаты Вы хоть что-то покажите, файлы, исходники, картинки, а то слова одни.


Простите за дилетантство - я еще совсем зелёный.:
Снимал на две камеры - sony a7mIII и a6300. Без цветового профиля. Ниже метаданные:

► Показать


Ниже скрины, сделанные с проигрывателя k-lite
Исходное видео
https://cloud.mail.ru/public/g6Sg/4nE76zaJm
Конвертированное из premiere в avi без потерь качества. Наилучше соответствует по цветопередаче
https://cloud.mail.ru/public/46U1/5eb2N9XJc
Конвертированное из premiere через h.264
https://cloud.mail.ru/public/3cd8/4wgEjrvjs
Avi конвертированное через sony vegas -драйвер sony tablet
https://cloud.mail.ru/public/2pMt/5nxnzLAwu

Если через любой другой конвертер AVI без потерь прогонять - он превращается по цветности в то что делает премьер через h264

Аватара пользователя

aeplug
Санта
Санта
Сообщения: 2471
Зарегистрирован: 18 мар 2016 23:20
Откуда: С Ютуба
Благодарил (а): 16 раз
Поблагодарили: 251 раз

Сообщение aeplug » 25 фев 2020 17:32

Изображение
Каким же образом это "Наилучше соответствует по цветопередаче"? Небо и земля.
Nuk_pro писал(а):Источник цитаты Снимал на две камеры

При чем тут ДВЕ камеры?
Nuk_pro писал(а):Источник цитаты скрины, сделанные с проигрывателя k-lite

не могут быть вообще доказательством чего-либо.
aeplug писал(а):Источник цитаты исходники

Это сами проблемные видео файлы, проекты, а не скрины из плеера.
Что мне с ними делать то?
Видео уроки для After Effects http://www.youtube.com/AEPlug
Платные консультации по работе в программах


Maestro
Нуб
Нуб
Сообщения: 7
Зарегистрирован: 08 май 2020 13:32

Сообщение Maestro » 08 май 2020 13:37

Присоединяюсь к теме. НЕ могу понять, почему у меня качество видео после кодирования хуже, чем в редакторе. Проще говоря - в Premiere Pro я делаю всю обработку, коррекцию люметри, всё как мне нравится. На экране просмотра (а это отдельный монитор у меня) всё красиво, хороший контраст, плавные градиенты без лесенок. Кодирую в H264 (пробовал и в H265, разницы нет почему-то) - и в конечном файле появляется пиксельность и лесенки на тёмных градиентах, картинка теряет часть насыщенности и контраста. Уже по-всякому бился, и в интернете информации не могу найти. В чём в принципе может быть проблема, куда копать? Исходная камера у меня снимает 1920*1080 с битрейтом около 20, с такими же параметрами и кодирую (если что).

Ситуация в целом прямо такая же, как у инициатора данной темы.

Аватара пользователя

aeplug
Санта
Санта
Сообщения: 2471
Зарегистрирован: 18 мар 2016 23:20
Откуда: С Ютуба
Благодарил (а): 16 раз
Поблагодарили: 251 раз

Сообщение aeplug » 08 май 2020 14:13

Maestro писал(а):Источник цитаты Кодирую в H264

264 всегда теряет качество, так уж он устроен.
Maestro писал(а):Источник цитаты с такими же параметрами и кодирую

Тем более два подряд кодирования 264 только ухудшают ситуацию, но это в целом основы кодирования.

Maestro писал(а):Источник цитаты картинка теряет часть насыщенности и контраста

Картинки показывайте :!: Где что? Плееры не считаются, сделал экспорт, засунул его назад в Premiere Pro и сравниваешь тут. Еще можно исходники эти куда-то выложить, чтобы другие смогли проверить на своих компьютерах.

Пока вот что я заметил - Premiere Pro как-то странно открывает 10 битные видео, они получаются рваные и цвета у них искажены, но я пока видел наоборот - более насыщено и контрастно получается. Мне присылали 265 для примера.
Забавно, что в After Effects этой проблемы не было.
Видео уроки для After Effects http://www.youtube.com/AEPlug
Платные консультации по работе в программах


Maestro
Нуб
Нуб
Сообщения: 7
Зарегистрирован: 08 май 2020 13:32

Сообщение Maestro » 08 май 2020 17:42

Прикладываю кадры из плеера и скриншот из редактора. В редакторе задний фон сплошной чёрный. Всё контрастное. В плеере (что медиаплеер классик, что стандартный виндовс - одинаково) всё будто светлее, задний фон уже не совсем чёрный и с пиксельным шумом местами (справа от сидящего человека видно и на всей границе света и тени, где поляна переходит в темноту). Контраст изображения хуже. И вот я не могу понять - неужели это действительно проблема - вывести конечный файл в том виде, в каком я вижу в редакторе? Ведь в редакторе всё нормально и красиво!
Вложения
пример кадра в плеере.jpg
пример кадра в плеере.jpg (264.52 КБ) 434 просмотра
пример кадра в плеере.jpg
пример кадра в плеере.jpg (264.52 КБ) 434 просмотра
пример кадра в редакторе.jpg
пример кадра в редакторе.jpg (711.72 КБ) 434 просмотра
пример кадра в редакторе.jpg
пример кадра в редакторе.jpg (711.72 КБ) 434 просмотра


Maestro
Нуб
Нуб
Сообщения: 7
Зарегистрирован: 08 май 2020 13:32

Сообщение Maestro » 08 май 2020 18:38

Как бы это сказать... Я закинул скодированное видео, которое мне не нравится в плеере, обратно в редактор - и всё нормально. Нет нареканий, красивый тёмный фон, хороший контраст и нет шумов. Это что за чёрная магия? Проблемы с кодеками? У меня стоял K-Lite, я думал что проблема в нём может и удалил его - ничего не изменилось. В плеер (в любом) изображение хуже, чем в редакторе.

А вот пример с ютуба с браузера тоже самое

Отправлено спустя 37 минут 29 секунд:
То есть оно залито на ютуб. И там артефакты ещё более явно заметны.
Вложения
пример кадра в ютубе.jpg
пример кадра в ютубе.jpg (683.91 КБ) 430 просмотров
пример кадра в ютубе.jpg
пример кадра в ютубе.jpg (683.91 КБ) 430 просмотров

Аватара пользователя

aeplug
Санта
Санта
Сообщения: 2471
Зарегистрирован: 18 мар 2016 23:20
Откуда: С Ютуба
Благодарил (а): 16 раз
Поблагодарили: 251 раз

Сообщение aeplug » 08 май 2020 22:06

У меня впечатление, что это пример кадра в редакторе.jpg неправильно показывает. На лицо явный Black Crush. Ствол справа не видно, колено утонуло в фоне, шея и щека тоже сливаются. Гамма занижена или 16-235 обрезало. Исходник покажи.
Видео уроки для After Effects http://www.youtube.com/AEPlug
Платные консультации по работе в программах


Вернуться в «Adobe Premiere Pro»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей